Small bugfix release

I updated NextGEN Gallery to V0.64 with three bugfixes. The arrow keys of the image browser damage the options , so you are not able to change them. This is a minor change , cause I need more time for the tagging. No new feature added.

Bugfix for the bugfix :

I did a small mistake in the include , it’s fixed now. Sorry !

Advertisements
Tagged ,

25 thoughts on “Small bugfix release

  1. alakhnor says:

    I’ll send you a mail tonight. I think we need to exchange on tags. 😉

  2. m.o.m. says:

    Hallo, ich bekomme eine Fehlermeldung “Warning once_include” in der Datei “nggallery.php” in der Zeile 158

    Original:
    include_once (dirname (__FILE__).”nggadmintab.php”);

    Ich habe das jetzt einfach von der Vorgängerversion übernommen. Und es geht mit meinem Workaround:

    include_once (“nggadmintab.php”);

    Liegt wohl am Pfad. Ich hatte jetzt die Dateien einfach in den vorhandenen Ordner kopiert. War bestimmt falsch 🙂

    Ansonsten grandioses Script!

  3. alex.rabe says:

    Ja da hab ich einen kleinen Fehler eingebaut :

    include_once (dirname (__FILE__).”/nggadmintab.php”);

    Es fehlte der Slash, wird heute abend geändert.

  4. m.o.m. says:

    Ok, das kann passieren 🙂

  5. Ty says:

    I’m having importing folders with large numbers of photos, 200-600 photos. Any ideas?

  6. alex.rabe says:

    @alakhnor

    Your ideas are always welcome

  7. Tomsn says:

    Ich habe heute auf V0.64 aktualisiert und es ist immer noch derselbe Fehler drinnen wie in allen älteren Versionen 😦
    Es geht um den hover Effectin der Thumbnail Übersicht: http://www.stillebacher.at/aus-dem-leben/hochwasser-in-voels/
    Der Fehler tritt im Firefox und im IE auf…

  8. m.o.m. says:

    @Tomsn.
    Das ist bestimmt kein Fehler. Schau mal die CSS vom WP-Template an und die CSS von NexgenGallery. Spiel da mal ein wenig rum.

    Bei mir geht es jedenfalls.
    http://momworx.de/webworx/

  9. Bobsch says:

    i’m using wordpress mu 1.2.3 – which is in fact a modification of wp 2.1 or 2.2^^

    –> but everytime i activate ngg i get this:
    Sorry, NextGEN Gallery works only under WordPress 2.1 or higher

    could you have a look into it? or tell me where i can find the version-check to remove it?^^

  10. peter says:

    I’m running apache web server which executes PHP scripts spawned with suexec so I think that checking if directory has 777 shouldn’t be so strict. In my environment the php scripts are executed with UID/GID of the owner of virtual server (php file), so all uploaded files are stored with proper UID/GID and not the apache_web_server UID/GID.

    “Directory wp-content/gallery/ didn’t have the permissions 777!”

    Due this strict checking I’m not able to use your great soft without code modifications. 🙂

    Greetings.

  11. Tomsn says:

    Vielen dank für’s aktive nichtstun 😦 habe nggallery gelöscht und mygall wieder verwendet…

  12. alex.rabe says:

    Wer lesen kann ist klar im Vorteil…

  13. Mann, Mann…
    eigentlich fällt mir zum Kommentar von Tomsn nichts mehr ein…

  14. alex.rabe says:

    Ich bin da auch platt (und ratlos) …

  15. floogy says:

    Tomsn scheint sich bei sich selbst zu bedanken, und neigt zu Selbstgesprächen…

    Jedenfalls bleibt mir völlig schleierhaft, weshalb er sonst so reagiert, da m.o.m. seine Frage ja bereits erschöpfend beantwortete.

    Ich bin da auch etwas ratlos.

  16. floogy says:

    @alex.rabe:
    Es würde mich freuen, wenn Du in das Plugin eine Erkennung von wpmu >1.2.x einbauen könntest, damit das Problem, welches Bobsch beschreibt nicht mehr auftritt, und ich es unter wpmu testen könnte.

    Ich wäre bereit eine vorab-version oder diff|patch zu testen.

    Icgh habe den role-manager 2.0.9 ins /plugin/ Verzeichnis installiert, der so einigermaßen unter wpmu funktioniert. Der Entwickler arbeitet bereits an einer wpmu-kompatiblen version.

  17. floogy says:

    Ich werde das hier mal testen, um zu versuchen das plugin in wpmu integriert zu bekommen:
    http://blog.rowancrane.com/category/wordpress-mu

  18. alex.rabe says:

    @floggy
    WPMU steht für den nächsten release auf der Liste

  19. floogy says:

    Ich habe es nun soweit zum laufen gebracht, mit dem merkwürdigen Gefühl nicht genau zu wissen, was alles nicht kompatibel zu wpmu sein könnte.
    Schön, dass Du ein wpmu release planst!

  20. floogy says:

    Ich habe es nun soweit zum laufen gebracht, mit dem merkwürdigen Gefühl nicht genau zu wissen, was alles nicht kompatibel zu wpmu sein könnte.
    Ich habe nun auch das forum dazu entdeckt:
    http://alexrabe.de/forums/?forum=5&topic=327

    Schön, dass Du ein wpmu release planst!

    Vielleicht hilft noch das hier:
    http://comox.textdrive.com/pipermail/wpmu-trac/2007-June/000645.html
    http://www.itdamager.com/category/wpmu-plugins/

  21. alex.rabe says:

    Danke für die Links,

    ich werde mir grosse Mühe geben das WPMU so gut wie möglich unterstützt wird + ein paar Extras für WPMU (Quota-Limits)

  22. floogy says:

    Das Plugin sorgt für Probleme mit der flash-plugin Erkennung.
    Leider kann ich nicht genau sagen, woran es hängt, zumal es schonmal Problemlos ging. Ah, habe jquery navigation eingeschaltet, mal schauen, ob es damit zusammenhängt. Denn die widgets gehen (slideschow/imagerotator).

    Hmmm… an jquery navi liegt es nicht, die ist wieder deaktiviert.

    The Flash Player and a browser with Javascript support are needed..

    Trotzdem: auf einer Subdomain der selben wpmu Installation läuft es.

    Was habe ich bei der anderen verstellt?

  23. floogy says:

    Das Problem mit der Pluginerkennung scheint zu bestehen, entweder wenn man die gleiche ID verwendet (zweimal [gallery=1] auf einer Seite, oder/und wenn in der sidebar ebenfalls das flash widget ist.

    Bei einer Testseite mit zweimal derselben Galerie und der Sidebar-Flashshow funktionieren die 2. Gaklerie mit derselben ID und das Sidebarwidget.

    Bei einer Seite mit einer Galerie und dem Sidebar Widget funktioniert nur das Sidebarwidget.

    Habe noch keine zwei Galerien angelegt, daher kann ich noch nicht sagen, wie es sich mit unterschiedlichen ID’s verhält. Ich gehe mal davo aus das es dann funktioniert.

    Ist ja auch unsinnig zweimal die gleiche Galerie zu verwenden 🙂

  24. alex.rabe says:

    @floggy

    Vielen Dank für deine Kommentare. Bei weiteren Fragen/Probleme verwende bitte das Forum, dort sind Sie besser aufgehoben !

Comments are closed.

%d bloggers like this: