NextGEN Gallery 1.8.0 Beta 1

Whoa… long break till the last release. I’m currently heavily busy with my daily work, so I need to slow down a bit the development the last months. Anyway something is changed under the hood. I’ve finally added the new permalink structure, as the current is ‘not-soooo-url-friendly’ and I’ve added a sorting option for the manage gallery page. Hope you like this improvement…

My next vacation is in front of me, so I decided to release a first second beta, that you are able to test this new features. I’m happy for any kind of feedback about this version.

Advertisements
Tagged

30 thoughts on “NextGEN Gallery 1.8.0 Beta 1

  1. Zach says:

    I’m using the 1.74 version of the plugin, however I’m no longer able to add a new gallery. Actually I can add the gallery, and the folder appears on the server but I can’t add pictures to it. I suspect the db isn’t getting updated with a new gallery number/name. How can I troubleshoot the issue? Is there a log somewhere I can review?
    Thanks

  2. Eric says:

    Great work! However I still experience a hardtime to creat thumbnail images. Everytime the progress bar reaches 100% but it would jam ever since. I already set the max memory to 128m but still no luck

  3. Iwan says:

    Also problems with 1.7.4. here. I can upload photo’s as usual but when I try to enter the gallery as a slideshow in the blog it looks like it can’t find the gallerylist. Howerver, it’s easy to just put [slideshow id=**] by hand in it. Let’s hope 1.8.0 is working, but since the buggy 1.6 update with months of no follow up I’m a bit scared to install it…

  4. Sven says:

    Hi Alex,

    thanks for the new version. I got still the following message after try to create thumbnails:

    Fatal error: Out of memory (allocated 34340864) (tried to allocate 10368 bytes) in /homepages/25/d29684285/htdocs/felixmarc/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 179

    I remove the comment in the gd.thumbnail.inc.php in line 164 (memory_limit), but nothing fix this problem.

    PHP has enough memory, but it seems, that the script doesn’t care about it. Here is the overview-output from nextgen Gallery:

    Operating System : Linux (32 Bit)
    Server : Apache
    Memory usage : 15.07 MByte
    MYSQL Version : 5.0.91-log
    SQL Mode : Not set
    PHP Version : 5.2.17
    PHP Safe Mode : Off
    PHP Allow URL fopen : Off
    PHP Memory Limit : 128MM
    PHP Max Upload Size : 200M
    PHP Max Post Size : 200M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Graphic Library

    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : No
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    Do you have any hints for me?

    thank you,
    Sven

  5. […] los gelegt und WordPress 3.2b1 drauf kopiert. Damit es nicht so einsam ist als Beta, gleich noch NextGEN Gallery 1.8b2 auf den Server geworfen. 2x Datenbank-Update und gleich geschaut…Geht eh alles noch Back- […]

  6. tatil says:

    Nice. Thank you ๐Ÿ™‚

  7. Kevin Vitali says:

    I tried the beta version and prior to this the previous version. I keep coming up with the same error:

    ERROR: Bedroom-2.jpg :
    Fatal error: Call to undefined function ssd_getoption() in /home/krvitali/public_html/wp-content/plugins/ss-downloads/ss-downloads.php on line 186

    any ideas that a simplton like me can do to fix?

  8. Sven says:

    Thanx Alex for the quick reply.

    I switched to a new hoster, because 1und1 is a crap. ๐Ÿ˜€

    After the installation of your plugin 1.7.4 the same problem with 64MB memory_limit. My client will not use smaller image, so I did the same linechange in the gd.thumbnail.inc.php in line 164 and uncommented the ini_set.

    After this all works fine and the thumbnails are created. ๐Ÿ™‚

  9. Carsten says:

    Hi

    was just wondering, I am running 1.7.4 and when I display the Gallery thumbnail representing th Gallery, and click on it, you see the whole collection of Thumbnails. But the title remains the one from the source page
    /gallerie/?album=2&gallery=2
    I would expect that the Name of the Gallery would be displayed rather than the “parent” title- Boring if it remains Gallery every where.
    Alternativly, I need to consider using pages and not ONE page summarizing all the galleries.

    Hope you can fix this befoer your next trip, or I need to fix it in PHP, somehow

    thanks!

  10. Paul says:

    Is there a way to protect my images from viewers copying them? Also, is there a way to put a watermark on all of my images that says copyright?

  11. Exact same error as this guy
    Fatal error: Out of memory (allocated 34340864) (tried to allocate 10368 bytes) in /homepages/25/d29684285/htdocs/felixmarc/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 179

    Just started happening recently with no changes?

  12. Don Sceifers says:

    OS Type Linux web506.opentransfer.com 2.6.18-238.9.1.el5PAE #1 SMP Tue Apr 12 18:52:55 EDT 2011 i686
    Server Software Apache
    PHP Version 5.2.17
    MySQL Server 5.0.51-log
    Memory Limit 64 MB
    Server Quota’s: show detailed ยป
    Storage Space 10.37 GB of 976.56 GB (1.06 %) used.
    Number of Files 48788 of 300000 files (16.26 %) stored.

    WP Version 3.1.2
    NextGen 1.7.4

    I’ve turned off all other plugins, and still cannot create thumbnails. Goes to 100% and hangs.

    Largest image is 500W and all are less than 100K in size.

    I am at IX Webhosting and this has never failed before. This is the first gallery I have created in a few months though.

    Any help?

  13. Xander says:

    Alex,

    I’m using v1.7.4 nextgen gallery plugin with wordpress and when I view jpgs which I’ve uploaded they appear blocky.

    How do I fix this so the images appear properly?

  14. Aaron Bentley says:

    The betaI noticed the ‘style’ admin option was missing from my wordPress multiSite network, meaning i couldn’t disable the default styles, to restore it go to wp-content/plugins/nextgen-gallery/admin
    Then open the admin.php file, the comment out/delete this line :

    if ( wpmu_enable_function(‘wpmuStyle’) )

    Should be around line 41, hope this helps someone ๐Ÿ™‚

  15. Pascal says:

    Hi Alex,

    First off, i love your plugin, works really perfect!
    Second, i am struggling with the permalinks most of the times, and i really think there is something wrong, let me elaborate:

    I have this permalink setting: /%category%/%postname%/

    in 1.7.4 (NextGen) when i insert a gallery on a PAGE, everything works perfect, however when i insert a gallery on a POST, thing are broken, and wordpress redirects me with a 301 back to the post (where the gallery is included).

    When i change the permalink to: /%post_id%/%category%/%postname%/

    Everything works perfect on both a PAGE and a POST.

    Whatever i do when using /%category%/%postname%/ things got broken with nextgen gallery

    Strangely enough i tried your 1.8 beta 2 with the /%category%/%postname%/ permalink, now things are exactly turned arround eg: POST do work, PAGES don’t (redirect me back to the page where the gallery is on).

    It seems that a permalink with /%category%/ in front breaks things. Any idea how to fix this or is this impossible todo because of the way wordpress works ?

    I really appreciate the work you do for the community, and love your plugin.

    Thanks in advance for your answer!

  16. Patrick says:

    I’m wondering it the latest WordPress update is causing havoc with thumbnail creation? That’s when I started to experience issues…

  17. ReplikSitesi says:

    you are doing good work.thank you.but i have a problem with your gallery widget.it doesnt work but i dont know whyy

  18. Aines says:

    Was the same problem with thumbnails and memory exceed e.t.c.
    It was fixed in new 1.8.0. beta.
    So, after 1000 unsuccessful attempts to fix something in memory and ini_set in 1.7.4 I just uploaded new version of plugin, deactivated old and activated new. After that updated 1.8.0.
    And now everything’s working. For now…

    But I’m still in testing mode.

  19. Jon says:

    Suggestion for future releases… my client wants the title to show below the thumbnail, and on the larger image in a slideshow.

    Odd that it is asked for in the image upload, but never shows anywhere…

    Thanks for developing this.

  20. I have a problem with the latest beta… i get the links something like this :

    mobilier-pentru-baie it`s the “album” “baie-dana” it`s a little gallery and “mobilier” it`s the slog

    http://www.miovidesign.ro/mobilier-pentru-baie/mobilier/mobilier-pentru-baie/baie-dana

  21. bastien says:

    the nextgen dont work with WP 3.1.3, the thumbnail process dont finish and dont make any thumbs on the website….

  22. mitch says:

    I’m noticing a formating and styling issue with the latest wp upgrade. It appears that nextgen removes a div when you are using the default wordpress gallery, instead of using nextgen.. which causes a major problem on the site. Any one else having the same issue or have any suggestions?

  23. Is there a possibility to create a virtual copy and put this one in another gallery? Now I have to upload the same image twice and in my recently added images widget the image shows twice.

  24. Nathan says:

    I’ve had a few ‘stuck’ thumbnail issues tooโ€ฆ

    On the out of memory error. I’ve noticed this message when an image is set to 300dpi and not 72dpi – and I also have an unresolved issue which seems to be something to do with colour profiles.

    I believe this is a GD issue and not actually the plugin – will post updates as I try and establish the exact issue, but just thought this info might help others having some of the upload issues.

  25. Hi guys,
    i’m installing the new 1.8.0 beta version now to try to solve the problem of thumbnails that not exist.
    Could anyone tel me how to change this memory “thing” to 128MB, as Alex is saying it should add to resolve the problem of thumbnails in some cases?
    I don’t know the reason in my case, but it’s been a long time that I try to put my thumbnails and it is just so frustating not having this allright.
    Thankyou verymuch guys.

  26. Alex,
    just installed 1.8 beta version. First thing i did, tryed to recreate thumbnails and also doesn’t work on this version. But now, the window for editing thumbnails one by one are problematic. It is transparent where i’m sure it should not be, so we can’t see an important part of it. We might guess where to close this window, for exemple.
    My computer is a mac very new and i’ve already tryied diferent browsers, as firefox, chrome and safari.
    Hope beein helpful,
    Tiago

  27. Mark S says:

    I am creating an e-shop site, I have tried eShop for WordPress but don’t like the way on the product page it shows all the details for each product.
    WP Simple Paypal Shopping cart does a nice job as it can use NextGen to show a page of thumbnails using the gallery-wp-eStore mod.
    But what I want to do is have a gallery where each thumbnail will link through to the relevant products post/page for them to place their order.
    The only way I can see of doing this is to manually code a page of thumbnails and link each image.

    Is there a way of creating a gallery where the thumbnails link to a post or page?

    Thanks, Mark

  28. dirk says:

    hi there!

    since the last flash update (i assume this is the cause) the batch upload doesn`t work with IE9 anymore. no select windows appears.
    This happens to 1.74 and 1.80RC1 as well.

    A plugin problem or some generic flash issue?

    best

  29. Tamson says:

    Just wanted to thank you for a great plug-in. Works great, no drama. Wow, what a change from other stuff I’ve been dealing with. ๐Ÿ™‚

Comments are closed.

%d bloggers like this: